Saturday 1 February 2020

MPLS VPN- PE-CE-Routing




Initial configuration on each routers. As below:

R1#sh ip int br | e una
Interface                  IP-Address      OK? Method Status      Protocol
Serial1/0                  11.0.0.2        YES manual up                    up
Serial1/1                  11.0.0.6        YES manual up                    up
Serial1/2                  10.0.0.1        YES manual up                    up
Loopback0               1.1.1.1         YES manual up                    up


R2#sh ip int br | e una
Interface                  IP-Address      OK? Method Status    Protocol
Serial1/0                  10.0.0.2        YES manual up                    up
Serial1/1                  10.0.0.5        YES manual up                    up
Loopback0               2.2.2.2         YES manual up                    up

R3#sh ip int br | e una
Interface                  IP-Address      OK? Method Status       Protocol
Serial1/0                  10.0.0.6        YES manual up                    up
Serial1/1                  10.0.0.9        YES manual up                    up
Loopback0               3.3.3.3         YES manual up                    up
R4#sh ip int br | e una
Interface                  IP-Address      OK? Method Status        Protocol
Serial1/0                  10.0.0.10       YES manual up                    up
Serial1/1                  11.0.0.9        YES manual up                    up
Serial1/2                  11.0.0.13       YES manual up                    up
Loopback0                  4.4.4.4         YES manual up                    up

R5#sh ip int b | e una
Interface                  IP-Address      OK? Method Status        Protocol
Serial1/0                     11.0.0.10       YES manual up                    up
Loopback0                  50.0.0.1        YES manual up                    up
Loopback1                  50.1.1.1        YES manual up                    up
Loopback2                  50.2.2.1        YES manual up                    up
R6#sh ip int b | e una
Interface                  IP-Address      OK? Method Status                Protocol
Serial1/0                    11.0.0.14       YES manual up                    up
Loopback0                  60.0.0.1        YES manual up                    up
Loopback1                  60.1.1.1        YES manual up                    up
Loopback2                  60.2.2.1        YES manual up                    up

R7#sh ip int b | e una
Interface                  IP-Address      OK? Method Status                Protocol
Serial1/0                     11.0.0.1        YES manual up                    up
Loopback0                  70.0.0.1        YES manual up                    up
Loopback1                  70.1.1.1        YES manual up                    up
Loopback2                  70.2.2.1        YES manual up                    up
R8#sh ip int b | e una
Interface                  IP-Address      OK? Method Status                Protocol
Serial1/0                     11.0.0.5        YES manual up                    up
Loopback0                  80.0.0.1        YES manual up                    up
Loopback1                  80.1.1.1        YES manual up                    up
Loopback2                  80.2.2.1        YES manual up                    up

When designing MPLS Keep in mind about the MPLS Architecture.
1.       Virtual Routing Forwarding
2.       Route Distinguisher
3.       PE-CE routing
4.       Router Target
5.       Route Propagation through M-BGP.
6.       Redistribute from PE - MBGP and vise versa .

Step 3 : PE-CE routing





Here we are going to enable RIP as our PE-CE routing between R1 and R7.
R1(config)#router rip
R1(config-router)#address-family ipv4 vrf a
R1(config-router-af)#network 11.0.0.0
R1(config-router-af)#no au
R1(config-router-af)#ver 2

R7(config)#router rip
R7(config-router)#net 11.0.0.0
R7(config-router)#net 70.0.0.0
R7(config-router)#no au
R7(config-router)#ver 2

Now on PE (R1) we might have got the rip routes. Lets check it.
R1#sh ip route vrf a | be Ga
Gateway of last resort is not set

     70.0.0.0/24 is subnetted, 3 subnets
R       70.2.2.0 [120/1] via 11.0.0.1, 00:00:04, Serial1/0
R       70.1.1.0 [120/1] via 11.0.0.1, 00:00:04, Serial1/0
R       70.0.0.0 [120/1] via 11.0.0.1, 00:00:04, Serial1/0
     11.0.0.0/30 is subnetted, 1 subnets
C       11.0.0.0 is directly connected, Serial1/0
R1#

Now lets enable eBGP as our PE-CE routing between R4 and R5.

R4(config)#router bgp 100
R4(config-router)#address-family ipv4 vrf a
R4(config-router-af)#neighbor 11.0.0.10 remote-as 65031


R5(config)#router bgp 65031
R5(config-router)#neighbor 11.0.0.9 remote-as 100
R5(config-router)#network 50.0.0.0 mask 255.255.255.0
R5(config-router)#network 50.1.1.0 mask 255.255.255.0
R5(config-router)#network 50.2.2.0 mask 255.255.255.0

R4#sh ip route vrf a | be Ga
Gateway of last resort is not set

     50.0.0.0/24 is subnetted, 3 subnets
B       50.2.2.0 [20/0] via 11.0.0.10, 00:01:07
B       50.1.1.0 [20/0] via 11.0.0.10, 00:01:07
B       50.0.0.0 [20/0] via 11.0.0.10, 00:01:07
     11.0.0.0/30 is subnetted, 1 subnets
C       11.0.0.8 is directly connected, Serial1/1

Now lets enable EIGRP as our PE-CE routing between R1 and R5.
Note: Here I have changed the topology.





R1(config)#router eigrp 1
R1(config-router)#address-family ipv4 vrf a
R1(config-router-af)#network 11.0.0.0 0.0.0.3
R1(config-router-af)#no au
R1(config-router-af)#autonomous-system 10

R5(config)#router eigrp 10
R5(config-router)#net 11.0.0.0 0.0.0.3
R5(config-router)#net 50.0.0.0 0.255.255.255
R5(config-router)#no au

R5#sh ip eigrp ne
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   11.0.0.1                Se0/0             12 00:00:07   48   288  0  4

R1#sh ip route vrf a | be Ga
Gateway of last resort is not set

     50.0.0.0/24 is subnetted, 3 subnets
D       50.2.2.0 [90/2297856] via 11.0.0.2, 00:00:33, Serial0/0
D       50.1.1.0 [90/2297856] via 11.0.0.2, 00:00:33, Serial0/0
D       50.0.0.0 [90/2297856] via 11.0.0.2, 00:00:33, Serial0/0
     11.0.0.0/30 is subnetted, 1 subnets
C       11.0.0.0 is directly connected, Serial0/0

Now lets enable OSPF as our PE-CE routing between R3 and R4.
R4(config)#router ospf 1
R4(config-router)#net 11.0.0.4 0.0.0.3  a 0
R4(config-router)#net 40.0.0.0 0.255.255.255 a 0

R3(config)#router ospf 10 vrf a
R3(config-router)#network 11.0.0.4 0.0.0.3 a 0

R3#sh ip route vrf a | be Ga
Gateway of last resort is not set

     40.0.0.0/32 is subnetted, 3 subnets
O       40.2.2.1 [110/65] via 11.0.0.6, 00:00:38, Serial0/0
O       40.1.1.1 [110/65] via 11.0.0.6, 00:00:38, Serial0/0
O       40.0.0.1 [110/65] via 11.0.0.6, 00:00:38, Serial0/0
     11.0.0.0/30 is subnetted, 1 subnets
C       11.0.0.4 is directly connected, Serial0/0

No comments:

Post a Comment