To publish the default network in an EIGRP
domain we have 3 methods. Lets take a look one by one
Method 1: Redistribution
On
R1 Create a static default route and then redistribute it in an EIGRP domain.
R2#sh run
ip route 0.0.0.0 0.0.0.0 Ethernet1/0
!
R2#sh run
router eigrp 100
redistribute static
network 150.2.0.0
network 155.1.0.0
no
auto-summary
R6#sh ip route | in D*EX
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
D*EX 0.0.0.0/0 [170/2198016] via
155.1.156.1, 00:02:39, FastEthernet0/0
BB2#traceroute 30.0.0.1
Type escape sequence to abort.
Tracing the route to 30.0.0.1
1
155.1.42.4 72 msec 96 msec 16 msec
2
155.1.14.1 44 msec 100 msec 40 msec
3
155.1.123.2 48 msec 24 msec 80 msec
4 * * *
Method 2: Summary Route
Lets
remove the static route on R2 and redistribution also.
R2#sh run int s0/0
interface Serial0/0
ip
address 155.1.123.2 255.255.255.0
encapsulation frame-relay
ip
summary-address eigrp 100 0.0.0.0 0.0.0.0 5
serial restart-delay 0
end
R6#sh ip route | in D* 0.0.0.0/0
D*
0.0.0.0/0 [90/2300416] via 155.1.156.1, 00:02:48, FastEthernet0/0
BB2#traceroute 30.0.0.1
Type escape sequence to abort.
Tracing the route to 30.0.0.1
1
155.1.42.4 96 msec 60 msec 32 msec
2
155.1.14.1 68 msec 24 msec 60 msec
3
155.1.123.2 20 msec 52 msec 12 msec
4 *
* *
Method 3: Default-Network
R2#sh run int lo 1
interface Loopback1
ip
address 1.0.0.1 255.0.0.0
end
!
router eigrp 100
network
1.0.0.0
network 150.2.0.0
network 155.1.0.0
no
auto-summary
!
ip default-network 1.0.0.0
R6#sh ip route | in D* 1.0.0.0/8
D*
1.0.0.0/8 [90/2300416] via 155.1.156.1, 00:01:13, FastEthernet0/0
BB2#traceroute 30.0.0.1
Type escape sequence to abort.
Tracing the route to 30.0.0.1
1
155.1.42.4 68 msec 48 msec 12 msec
2
155.1.14.1 52 msec 36 msec 32 msec
3
155.1.123.2 100 msec 16 msec 20 msec
4 *
* *
No comments:
Post a Comment